Opera 10.70 Pet Instructions

Click here to view the Murga-Linux Puppy forum Topic about this file.

Believe this will work on most Puppies 4 and up.